Josh-Daniel S. Davis (joshdavis) wrote in eserver,
Josh-Daniel S. Davis
joshdavis
eserver

Manually removing an LV and other woes

System was installed on hdisk0
New disk came in at hdisk4.
migrated to hdisk4, bosboot, bootlist.
hdisk0 is gone.
boot failure for unknown reasons. Hangs at "Starting the Kernel".

###Access a Root Volume Group has problems.
0516-622 synclvodm: Warning, cannot write lv control block tada.
ln: /dev/r: No such file or directory
getlvodm: option requires an argument -- l
0516-104 lquerylv: Incorrect LV identifier. The format must be
VG_identifier.LV_minor_number


###lspv shows it on hdisk4, but the running kernel has it as hdisk0.
bosboot -ad hdisk4
0518-507 odmget: Could not retrieve object for CuAt, ODM error number 5904
bosboot: Boot image is 46871 512 byte blocks.
0301-162 bosboot: savebase failed with /dev/hdisk4.
0301-165 bosboot: WARNING! bosboot failed - do not attempt to boot device.
reboot
PReP-BOOT : Unable to load full PReP image.
Loaded 0 out of 1702e00 bytes.
No OS image was detected by firmware.
At leasrt one disk in the bootlist was not found yet.
Firmware is now retrying the entries in the bootlist.
Press ctrl-C to stop retrying.

###Access a root volume group again
rmlv -f hd5
mklv -ae -em -tboot -yhd5 rootvg 2
bosboot -ad hdisk4
0516-1734 rmlv: Warning, savebase vailed. Please manually run 'savebase' before rebooting.
0518-507 odmget: Could not retrieve object for CuAt, ODM error number 5904
0301-111 /usr/lib/boot/bin/mkboot_chrp: error on Object Data Manager routine "odm_get_first"
0301-158 bosboot: mkboot failed to create bootimage.
0301-165 bosboot: WARNING! bosboot failed - do not attempt to boot device.

### Tried hardlinking the real disk's dev entries to the one disk ODM wants, but no changes.
### rmdev and cfgmgr didn't help
next boot gave
0516-010 : Volume group must be varied on; use varyonvg command.
0516-168 bosboot: The current boot logical volume, /dev/hd5, does not exist on /dev/hdisk4

rmlv -f hd5
0516-306 getlvoodm: Unable to find hd5 in the Device
Configuration Database.
0516-912 rmlv: Unable to remove logical volume hd5.
0516-1734 rmlv: Warning, savebase failed. Please manually run 'savebase' before rebooting.


Ultimately, I had to odmget | grep -p hdisk4, edit all of the entries, odmdelete -o $class -q "name=hdisk4" and such (name, value3, dependency), then re-add the edited entries so that the rootvg disk matched what maint mode finds it as.

Then, I had to manually remove hd5 since it was severely broken:

lqueryvg -p hdisk0 -At
copy the LVID (VGID.###)
lquerylv -L $LVID -r > /tmp/1
LPS=`wc -l /tmp/1`
lreducelv -l $LVID -s $COUNT /tmp/1

mklv and bosboot worked fine after that, but bootlist did not because hdisk0 wasn't available due to it already being brought up from ramfs. I had to boot to SMS, choose the OS disk, and then run bootlist from inside the running OS.

Now I'm back to the point of hanging at "Starting kernel". These are "MPIO Other FC SCSI Disk Drive", a netapp device hanging off of NPIV.

Now to go dig up my old steps for doing a debug boot... *sigh*
These all seem like issues that should not occur at this stage of the game with AIX.
Subscribe
  • Post a new comment

    Error

    default userpic
    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 3 comments