Josh-Daniel S. Davis (joshdavis) wrote in eserver,
Josh-Daniel S. Davis
joshdavis
eserver

broken bos.rte.security

In a couple of instances, I've found bos.rte.* filesets broken during upgrade, perhaps with the root part missing.

It's always a pain, and I always forget how to fix it.

The problem is that the AIX base media does not include base install images for these. They are S (single) updates instead of I (install) images. This is because, during install, a bff called "bos" is laid down first, and that includes 10-20 core filesets, /usr, /, and all the core stuff. It's basically a prototype mksysb. Sort of.

Anyway, in rare instances, when there is a known defect, IBM will release a fileset as a patch through support/ztrans to get you fixed. If you don't have time to wait, or if you are a biz partner, working with a customer who hasn't yet approved you using their support, then you might have to fix it yourself.


# install_all_Updates -cYd /export/lppsource/AIX_7.1.4.1_TLSP
+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...
0503-466 installp: The build date requisite check failed for fileset     bos.rte.security.
Installed fileset build date is 1415.  Selected fileset does not have a build date, but one is required.
installp: Installation failed due to BUILDDATE requisite failure.

install_all_updates: Checking for recommended maintenance level 7100-04.
install_all_updates: Executing /usr/bin/oslevel -rf, Result = 7100-03
install_all_updates: ATTENTION, the system recommended maintenance level
does not correspond to the highest level known to install_all_updates.
For more details, execute /usr/bin/oslevel -rl 7100-04.

install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = FAILURE


# installp -acXYd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.security
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...Verifying requisites...done
Results...

FAILURES
--------
  Filesets listed in this section failed pre-installation verification
  and will not be installed.

  Requisite Failures
  ------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  install.  They cannot be installed until all of their requisite filesets
  are also installed.  See subsequent lists for details of requisites.

    bos.rte.security 7.1.4.0                  # Base Security Function

  CONFLICTING REQUISITES:  The following filesets are required by one or
  more of the selected filesets listed above.  There are other versions of
  these filesets which are already installed (or which were selected to be
  installed during this installation session).  A base level fileset cannot
  be installed automatically as another fileset's requisite when a different
  version of the requisite is already installed.  You must explicitly select
  the base level requisite for installation.

    bos.64bit 7.1.4.0                         # Base Operating System 64 bit...
    bos.acct 7.1.4.0                          # Accounting Services
    bos.adt.include 7.1.4.0                   # Base Application Development...
    bos.mp64 7.1.4.0                          # Base Operating System 64-bit...
    bos.perf.libperfstat 7.1.4.0              # Performance Statistics Libra...
    bos.perf.perfstat 7.1.4.0                 # Performance Statistics Inter...
    bos.perf.proctools 7.1.4.0                # Proc Filesystem Tools
    bos.perf.tools 7.1.4.0                    # Base Performance Tools
    bos.pmapi.pmsvcs 7.1.4.0                  # Performance Monitor API Kern...
    bos.wpars 7.1.4.0                         # AIX Workload Partitions
    mcr.rte 7.1.4.0                           # Metacluster Checkpoint and R...
    perfagent.tools 7.1.4.0                   # Local Performance Analysis &...

  MISCELLANEOUS FAILING REQUISITES:  The following filesets are requisites
  of one or more of the selected filesets listed above.  Various problems
  associated with these requisites are preventing the selected filesets
  from installing.  See the "Requisite Failure Key" for failure reasons and
  possible recovery hints.

    < bos.rte.security 7.1.3.30               # Base Security Function

  Requisite Failure Key:
  "<" superseded fileset that is applied on the "usr" part which must
      also be applied on the "root" part for consistency.  Select this
      fileset explicitly or use the option to automatically include
      requisite software (-g flag).

  AVAILABLE REQUISITES:  The following filesets are requisites of one or
  more of the selected filesets listed above.  They are available on
  the installation media.  To install these requisites with the selected
  filesets, specify the option to automatically install requisite
  software (-g flag).

    bos.rte.control 7.1.4.0                   # System Control Commands
    bos.rte.libc 7.1.4.0                      # libc Library

  << End of Failure Section >>

+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...done
FILESET STATISTICS
------------------
    1  Selected to be installed, of which:
        1  FAILED pre-installation verification
  ----
    0  Total to be installed


Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
bos.rte.security          7.1.4.0         Requisite failure

# installp -acXYFd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.security
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...

Pre-installation Failure/Warning Summary
----------------------------------------
0503-500 installp:  After completion of pre-installation processing,
        there were no installable base level filesets found on the
        installation media.  Note that use of the force install option
        (-F flag) will cause installp to consider only base level filesets
        (fileset updates will be ignored).  No installation has occurred.


So then I installed these, thinking maybe....
  bos.64bit 7.1.4.0                           # Base Operating System 64 bit...
  bos.acct 7.1.4.0                            # Accounting Services
  bos.adt.include 7.1.4.0                     # Base Application Development...
  bos.mp64 7.1.4.0                            # Base Operating System 64-bit...
  bos.perf.libperfstat 7.1.4.0                # Performance Statistics Libra...
  bos.perf.perfstat 7.1.4.0                   # Performance Statistics Inter...
  bos.perf.proctools 7.1.4.0                  # Proc Filesystem Tools
  bos.perf.tools 7.1.4.0                      # Base Performance Tools
  bos.pmapi.pmsvcs 7.1.4.0                    # Performance Monitor API Kern...
  bos.wpars 7.1.4.0                           # AIX Workload Partitions
  mcr.rte 7.1.4.0                             # Metacluster Checkpoint and R...
  perfagent.tools 7.1.4.0                     # Local Performance Analysis &...

bos.rte.control 7.1.4.0 # System Control Commands

But no joy. bos.rte.libc and bos.rte.security depend on eachother, and it still fails with the top errors.

# installp -acXYd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.security
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...Verifying requisites...done
Results...

FAILURES
--------
  Filesets listed in this section failed pre-installation verification
  and will not be installed.

  Requisite Failures
  ------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  install.  They cannot be installed until all of their requisite filesets
  are also installed.  See subsequent lists for details of requisites.

    bos.rte.security 7.1.4.0                  # Base Security Function

  MISCELLANEOUS FAILING REQUISITES:  The following filesets are requisites
  of one or more of the selected filesets listed above.  Various problems
  associated with these requisites are preventing the selected filesets
  from installing.  See the "Requisite Failure Key" for failure reasons and
  possible recovery hints.

    < bos.rte.security 7.1.3.30               # Base Security Function

  Requisite Failure Key:
  "<" superseded fileset that is applied on the "usr" part which must
      also be applied on the "root" part for consistency.  Select this
      fileset explicitly or use the option to automatically include
      requisite software (-g flag).

  AVAILABLE REQUISITES:  The following filesets are requisites of one or
  more of the selected filesets listed above.  They are available on
  the installation media.  To install these requisites with the selected
  filesets, specify the option to automatically install requisite
  software (-g flag).

    bos.rte.libc 7.1.4.0                      # libc Library

  << End of Failure Section >>

+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...done
FILESET STATISTICS
------------------
    1  Selected to be installed, of which:
        1  FAILED pre-installation verification
  ----
    0  Total to be installed


Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
bos.rte.security          7.1.4.0         Requisite failure



# installp -acXYd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.libc
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...Verifying requisites...done
Results...

FAILURES
--------
  Filesets listed in this section failed pre-installation verification
  and will not be installed.

  Requisite Failures
  ------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  install.  They cannot be installed until all of their requisite filesets
  are also installed.  See subsequent lists for details of requisites.

    bos.rte.libc 7.1.4.0                      # libc Library

  MISCELLANEOUS FAILING REQUISITES:  The following filesets are requisites
  of one or more of the selected filesets listed above.  Various problems
  associated with these requisites are preventing the selected filesets
  from installing.  See the "Requisite Failure Key" for failure reasons and
  possible recovery hints.

    < bos.rte.security 7.1.3.30               # Base Security Function

  Requisite Failure Key:
  "<" superseded fileset that is applied on the "usr" part which must
      also be applied on the "root" part for consistency.  Select this
      fileset explicitly or use the option to automatically include
      requisite software (-g flag).

  AVAILABLE REQUISITES:  The following filesets are requisites of one or
  more of the selected filesets listed above.  They are available on
  the installation media.  To install these requisites with the selected
  filesets, specify the option to automatically install requisite
  software (-g flag).

    bos.rte.security 7.1.4.0                  # Base Security Function

  << End of Failure Section >>

+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...done
FILESET STATISTICS
------------------
    1  Selected to be installed, of which:
        1  FAILED pre-installation verification
  ----
    0  Total to be installed


Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
bos.rte.libc              7.1.4.0         Requisite failure


# installp -acXYFd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.libc
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...

Pre-installation Failure/Warning Summary
----------------------------------------
0503-500 installp:  After completion of pre-installation processing,
        there were no installable base level filesets found on the
        installation media.  Note that use of the force install option
        (-F flag) will cause installp to consider only base level filesets
        (fileset updates will be ignored).  No installation has occurred.



# installp -acXYd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.security bos.rte.libc
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...Verifying requisites...done
Results...

SUCCESSES
---------
  Filesets listed in this section passed pre-installation verification
  and will be installed.

  Selected Filesets
  -----------------
  bos.rte.libc 7.1.4.0                        # libc Library
  bos.rte.security 7.1.4.0                    # Base Security Function

  Requisites
  ----------
  (being installed automatically;  required by filesets listed above)
  bos.rte.security 7.1.3.30                   # Base Security Function

  << End of Success Section >>

+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...
0503-466 installp: The build date requisite check failed for fileset     bos.rte.security.
Installed fileset build date is 1415.  Selected fileset does not have a build date, but one is required.
installp: Installation failed due to BUILDDATE requisite failure.




# installp -C
0503-439 installp:  No filesets were found in the Software Vital
        Product Database that could be cleaned up.



# installp -c all
+-----------------------------------------------------------------------------+
                        Pre-commit Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...

WARNINGS
--------
  Problems described in this section are not likely to be the source of any
  immediate or serious failures, but further actions may be necessary or
  desired.

  Nothing to Commit
  -----------------
  There is nothing in the APPLIED state that needs to be committed.

  << End of Warning Section >>



# lslpp -h bos.rte.security
  Fileset         Level     Action       Status       Date         Time
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  bos.rte.security
                  7.1.3.0   COMMIT       COMPLETE     07/25/14     09:44:45
                 7.1.3.15   COMMIT       COMPLETE     11/20/14     11:25:13
                 7.1.3.30   COMMIT       COMPLETE     12/08/14     02:47:41

Path: /etc/objrepos
  bos.rte.security
                  7.1.3.0   COMMIT       COMPLETE     07/25/14     09:44:45
                 7.1.3.15   COMMIT       COMPLETE     11/20/14     11:25:14



# installp -rBXJw bos.rte.security
+-----------------------------------------------------------------------------+
                        Pre-reject Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...

WARNINGS
--------
  Problems described in this section are not likely to be the source of any
  immediate or serious failures, but further actions may be necessary or
  desired.

  Not Rejectable
  --------------
  No software could be found installed on the system that could be rejected
  for the following requests:

    bos.rte.security

  (Possible reasons for failure:  1. the selected software has been
   committed, i.e., cannot be rejected, 2. the selected software is not
   installed, 3. the pre-reject script failed, or 4. a typographical
   error was made.)

  << End of Warning Section >>

FILESET STATISTICS
------------------
    1  Selected to be rejected, of which:
        1  FAILED pre-reject verification
  ----
    0  Total to be rejected


Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
bos.rte.security                          Failed pre-rejection check



# lppchk -vm3
lppchk:  The following filesets need to be installed or corrected to bring
         the system to a consistent state:

  bos.rte.security 7.1.3.30               (usr: COMMITTED, root: not installed)


# installp -acXYFd /export/lppsource/AIX_7.1.4.0_Base/installp/ppc bos.rte.security bos.rte.libc
+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...

Pre-installation Failure/Warning Summary
----------------------------------------
0503-500 installp:  After completion of pre-installation processing,
        there were no installable base level filesets found on the
        installation media.  Note that use of the force install option
        (-F flag) will cause installp to consider only base level filesets
        (fileset updates will be ignored).  No installation has occurred.


The solution was ODM surgery.

First, I took a mksysb and copied it to somewhere safe (another server with NIM installed).

Then, I looked into ODM, and found /etc/objrepos/product was missing the entry for this version.
You might be able to copy from /usr/lib/objrepos, but I copied from a valid clone of this system.

# export ODMDIR=/etc/objrepos
# ssh goodserver odmget -q lpp_name=bos.rte.security product | odmadd


Then, I needed to add the history line, which was identical between root and usr:
# odmget -q name=bos.rte.security lpp     (note the lpp_id)
# ODMDIR=/usr/lib/objrepos odmget -q lpp_name=39 history | ODMDIR=/etc/objrepos odmadd


The "inventory" ODM is accessed with lpp_name also, but that had a long list of files already. I did not mess with any of that.

Now, install_all_updates from my TLSP worked fine.
Tags: aix, lpp, odm, surgery
  • Post a new comment

    Error

    default userpic
  • 0 comments